Lead Imports Delayed
Incident Report for LeadSimple
Resolved
This incident has been resolved.
Posted Jun 01, 2020 - 13:28 PDT
Monitoring
An SSL certificate in our chain of trust expired on May 30. This interrupted new lead imports starting on May 30. No leads were lost. They are importing now.
Posted Jun 01, 2020 - 11:10 PDT
Identified
Lead imports are delayed due to a technical issue with our email provider. We are in contact with them and will update this as we have more information.
Posted Jun 01, 2020 - 10:33 PDT
This incident affected: Lead Imports.