Web Service Disruption
Incident Report for LeadSimple
Resolved
This appears to have been an upstream problem with our hosting provider, which has been resolved.
Posted May 23, 2016 - 08:56 PDT
Investigating
We've detected a spike in request queuing time, and are investigating.
Posted May 23, 2016 - 08:36 PDT