Degraded Performance
Incident Report for LeadSimple
Resolved
Performance is now normal.
Posted Apr 29, 2020 - 21:11 PDT
Update
Performance seems to have normalized. We are continuing with our plan to upgrade infrastructure.
Posted Apr 29, 2020 - 15:48 PDT
Identified
Since 8 AM PDT this morning, the app has experienced degraded performance. We have identified a likely cause and are upgrading our infrastructure.
Posted Apr 29, 2020 - 14:44 PDT
This incident affected: App.