Call recordings not downloading
Incident Report for LeadSimple
Resolved
All call recordings have been restored and this incident is now resolved.
Posted Nov 22, 2022 - 18:00 PST
Identified
We are aware of an issue that is causing call recordings to not appear in LeadSimple. This issue affects call recordings from the past few hours. We are rolling out a fix now and will continue to monitor.
Posted Nov 22, 2022 - 14:29 PST
This incident affected: Outbound Phone Calls.