Email Import Delays
Incident Report for LeadSimple
Resolved
Our email provider reports that all email queues have been processed, so there should be no more delays.
Posted Apr 25, 2016 - 14:49 PDT
Monitoring
Our email provider confirmed the problem and full function has been restored.
Posted Apr 25, 2016 - 14:34 PDT
Investigating
A few clients have reported delays in importing new email leads. We believe the issue is with our upstream email provider, and are in communication with them to confirm and fix.
Posted Apr 25, 2016 - 13:04 PDT