Partial S3 outage
Incident Report for LeadSimple
Resolved
AWS has resolved the outage, and our upstream providers are reporting status restored.

Some users reported email delays, lead import delays, and inability to upload files. All of these issues should now be resolved.
Posted Feb 28, 2017 - 15:53 PST
Investigating
We are investigating a partial outage due to our use of AWS S3. Currently the impact seems to be limited to our upstream email providers, and may negatively affect sending and receiving email with attachments.
Posted Feb 28, 2017 - 10:46 PST