Email delivery provider is down
Incident Report for LeadSimple
Resolved
The incident has been resolved by Sendgrid.
Posted Jul 28, 2020 - 16:43 PDT
Identified
Customers sending email without a connected email account may experience a "421 Service Error." This is due to downtime on our email provider, Sendgrid. https://status.sendgrid.com/incidents/c2k6nqpr9t7p
Posted Jul 28, 2020 - 11:12 PDT
This incident affected: Email Delivery.