High Database Load
Incident Report for LeadSimple
Resolved
We're satisfied that the problem is resolved for now, but we're continuing to investigate the root cause.
Posted Apr 15, 2021 - 14:16 PDT
Monitoring
We believe we've identified the problem, and performance has significantly improved. We're continuing to monitor.
Posted Apr 15, 2021 - 11:45 PDT
Investigating
We're currently investigating an issue with above average database load.
Posted Apr 15, 2021 - 11:08 PDT
This incident affected: App.