Degraded Performance on Lead Search
Incident Report for LeadSimple
Resolved
This incident has been resolved.
Posted Apr 23, 2020 - 17:21 PDT
Update
Performance appears back to normal. We're continuing to monitor to be sure.
Posted Apr 23, 2020 - 14:49 PDT
Monitoring
We rolled back the search changes so that we could perform more optimizations on them. We're monitoring the performance of the app, which appears to be returning to normal.
Posted Apr 23, 2020 - 14:31 PDT
Identified
We are rolling out an update to significantly improve lead search speed across all accounts. Unfortunately, the process of building the index is causing performance issues with search on accounts where the index is not finished. We're monitoring the situation and expect it to clear up soon.
Posted Apr 23, 2020 - 14:00 PDT
This incident affected: App.