Microsoft 365 Outage
Incident Report for LeadSimple
Resolved
This incident has been resolved.
Posted Mar 15, 2021 - 17:10 PDT
Update
The issue appeared to be resolved at 3:15pm PST, consistent with Microsoft's status page: https://status.office.com/.
Posted Mar 15, 2021 - 17:10 PDT
Monitoring
Microsoft just posted a status update:
> Current status: We are currently rolling out a mitigation worldwide. Customers should begin seeing recovery at this time, and we anticipate full remediation within 60 minutes.
Posted Mar 15, 2021 - 14:25 PDT
Identified
At approximately 1pm PST, users started reporting errors when attempting to send emails through their connected Microsoft Exchange / Office 365 accounts.

Microsoft has reported that their service is down, and they are working on bringing things back online:
1. https://status.office.com/
2. https://twitter.com/MSFT365Status/status/1371554704518352896

This issue does not affect other types of connected accounts (Gmail, IMAP/SMTP).
Posted Mar 15, 2021 - 13:50 PDT
This incident affected: Email Delivery.