Twilio intermittent failures

Incident Report for LeadSimple

Update

The upsteam provider is reporting the issues are now cleared.
Posted Sep 02, 2026 - 10:42 PDT

Update

We are continuing to monitor for any further issues.
Posted Sep 01, 2026 - 11:11 PDT

Monitoring

An upstream provider is currently experiencing intermittent failures.
Posted Sep 01, 2026 - 11:11 PDT
This incident affects: Outbound SMS, Outbound Phone Calls, Twilio SMS, Twilio MMS, and Twilio TwiML.