Emails are not showing up in inbox for some customers
Incident Report for LeadSimple
Resolved
All emails/email accounts have been restored.

We apologize for the trouble throughout the whole day. We'll have a postmortem describing what caused the problem on this Status Page soon.
Posted Apr 10, 2024 - 14:00 PDT
Update
Most of the affected email accounts/emails have been reconnected. We are still working through the list of affected accounts. No email account connections/email data has been lost. The current ETA is 4 PM Eastern Time.

We apologize for the huge inconvenience this has caused.
Posted Apr 10, 2024 - 11:41 PDT
Update
We are still in the process of reconnecting the missing email accounts/emails. The current ETA for full recovery of emails/email accounts is 3 PM Eastern Time.
Posted Apr 10, 2024 - 09:40 PDT
Update
We are still in the process of reconnecting the accounts. The current ETA for full recovery of emails/email accounts is 1 PM Eastern Time.
Posted Apr 10, 2024 - 08:49 PDT
Identified
We are aware that some customers are not able to see their emails in Inbox. Some customers might also not be seeing some of their connected email addresses. We have already identified the root cause and are working on a fix. No email or email address data has been lost.
Posted Apr 10, 2024 - 08:10 PDT
This incident affected: App.