Customers reporting 504 errors
Incident Report for LeadSimple
Resolved
This incident has been resolved.
Posted Nov 05, 2024 - 13:26 PST
Monitoring
We are monitoring the results.
Posted Nov 05, 2024 - 13:25 PST
Update
We are continuing to investigate this issue.
Posted Nov 05, 2024 - 13:25 PST
Update
We are continuing to investigate this issue.
Posted Nov 05, 2024 - 12:49 PST
Investigating
We are currently investigating this issue.
Posted Nov 05, 2024 - 12:10 PST
This incident affected: App, Website, Email Delivery, Outbound SMS, Notifications, and Lead Imports.