Generalized Slowness
Incident Report for LeadSimple
Resolved
This incident has been resolved.
Posted Jun 02, 2023 - 13:59 PDT
Update
The app is now running smoothly again.

We are still investigating the automated tasks delay.
Posted Jun 02, 2023 - 13:15 PDT
Update
We are seeing improvements in performance (and reduced delays), while we continue investigating.
Posted Jun 02, 2023 - 12:47 PDT
Update
We are continuing to investigate this issue.
Posted Jun 02, 2023 - 12:19 PDT
Investigating
LeadSimple has been running slowly. We are investigating the causes.

You might see delays on stage changes, emails, text messages, and zap triggers. We've already identified the root cause for the delays, we are monitoring our solution. No data was lost.
Posted Jun 02, 2023 - 12:18 PDT
This incident affected: App, Website, Email Delivery, Outbound SMS, Notifications, Twilio SMS, REST API, and Zapier.