Ongoing AWS Service Disruption

Incident Report for LeadSimple

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 05:59 PDT

Monitoring

We’re currently experiencing partial service disruption due to a widespread AWS outage affecting our infrastructure provider. This may impact some users’ ability to access or perform certain actions within LeadSimple.

Our systems remain stable, and we’re actively monitoring the situation while AWS works to resolve the issue. We’ll continue to provide updates as more information becomes available.
Posted Oct 20, 2025 - 07:28 PDT
This incident affected: App, Website, Email Delivery, Outbound SMS, Outbound Phone Calls, Notifications, Lead Imports, Enterprise Dashboard, Twilio SMS, Twilio MMS, Twilio TwiML, and AWS cloudfront.