Degraded performance in search

Incident Report for LeadSimple

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 14:15 PDT

Update

We are continuing to investigate this issue.
Posted Jul 08, 2025 - 14:15 PDT

Update

We are continuing to investigate this issue.
Posted Jul 08, 2025 - 10:47 PDT

Investigating

We are currently investigating this issue.
Posted Jul 08, 2025 - 10:46 PDT
This incident affected: App, Email Delivery, Outbound SMS, Lead Imports, REST API, and Integrations.