Emails can't be accessed in Inbox
Incident Report for LeadSimple
Resolved
The proposed fix has solved the problem, inbox can now be accessed again.
Posted Mar 14, 2024 - 12:30 PDT
Monitoring
A fix has been implemented, we're releasing the fix and monitoring it.
Posted Mar 14, 2024 - 12:17 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 14, 2024 - 12:08 PDT
Investigating
We are currently investigating reports of Inbox not being able to display an email conversation. The problem started at 11:01 AM PDT.
Posted Mar 14, 2024 - 11:01 PDT
This incident affected: App.